Notification email - ticket hyperlink corrupted

Document ID : KB000105657
Last Modified Date : 06/07/2018
Show Technical Document Details
Issue:
An error in the HTML source of message template is not detected by CA SDM, View and Quick View do not indicate the presence of any errors. 
 
For example, the error may cause corruption of the hyperlink for accessing the ticket via the email notification sent by CA Service Desk Manager that is received by an object contact.

Possible steps to reproduce:
 
1. Edit the out-of-the-box "Notifications > Messages Templates" named "Default Log Comment message template for request/incident/problem". 
2. Click on "edit HTML Message" 
3. Click the "Source" tab 
4. Starting at the top of the text, search for "href=", finding it after "title=". Change the existing: 
href="@{call_req_id.web_url}" 
to: 
href="testbad@{call_req_id.web_url}" 
5. click "OK" to save the change. 
6. Assuming Auto Notification is set to Yes for the message template of step#1 and that the default setup of Log Comment activity notification is associated to the out-of-the-box notification rule named "Default Log Comment Notification Rule for request/incident/problem" which is associated to the message template of step#1 and has the Assignee as an Object Contacts, , view an active incident which has an assignee of an analyst contact having notification method set to Email and a valid email address. 
7. in the Incident Detail, click Activities and select Log Comment 
8. Confirm that the notification email is received by the assignee. Click on the "Incident <ref_num> Log Comment Notification" or right-click and select "Copy shortcut". 
Results: The hyper link is incorrect, it is like: 
testbadhttp:/sdmservername:8080/CAisd/pdmweb.exe?OP=SEARCH+FACTORY=cr+SKIPLIST=1+QBE.EQ.id=400703 

Confirmed that there is no indication of the presence of an error in the source html when using "View" to display the HTML Message of the Log Comment message template. 
Environment:
Known to occur with CA Service Desk Manager 14.1 / 17.1 on Windows
Cause:
The HTML source of the message template contains an error that was entered manually.

The View and Quick View only show what the email user would see, so the names of hyperlinks and not the underlying link.

In the example, to confirm the URL of the named link, when in View for the message template, hover your mouse over this part:
@{call_req_id.type.sym} @{call_req_id.ref_num}
of this statement:
@{call_req_id.type.sym} @{call_req_id.ref_num} @{type.sym} Notification

show hover results




 
Resolution:
Review the HTML Source for the message template for any errors.
 
In the example, check the value of "href".

In the steps to reproduce, the resolution would be to perform the following steps:

1. Starting at the top of the text, search for "href=", finding it after "title=".
2. Change the existing: 
href="testbad@{call_req_id.web_url}" 
to
href="@{call_req_id.web_url}"