Not able to set status transition condition for Request workflow tasks

Document ID : KB000110863
Last Modified Date : 10/08/2018
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Issue:
*****SUMMARY ***** 

SDM 17.x

"Condition" field missing from "To Do" tab and "Attribute Transition Condition" field missing from "Transition Information" tab on "Create New Behavior Template" form (detail_bhvtpl.htmpl) ONLY for R/I/P but not for Change Orders 
These are defects that were found in 14.1.01 with test fixes created but I guess these fixes were never moved into later releases. 

"PROBLEM SYMPTOM: WIN-CANNOT ADD A CONDITION TO BEHAVIOR TEMPLATE "

Steps to reproduce: 

1. Login to Service Desk Manager. 
2. Navigate to 'Administration' -> 'ServiceDesk' ->'Request/Incident/Problem' -> 'Area'. Open detail page of any Area. 
3. Click on the 'Workflow' tab. Under that select any sub tab and click Edit. 
4. Click on 'Use Classic Workflow' and create a new Workflow template and save. 
5. Open the Workflow template created in Step#4. Under 'Behavior' tab, open any behavior from the template list and try to add a Condition. 

Result: 

'Condition' field is missing under the 'To Do' tab. 'Condition' can be added for behavior 
templates of Workflow templates of Change Order and Issue Categories. 
Environment:
Service Desk Manager 17.x
Cause:
This issue is caused by the DEFECT #DE42205
Resolution:
Fix provided in the DEFECT #DE42205