Not able to see the Toolbox Dock in Agile Designer

Document ID : KB000007251
Last Modified Date : 14/02/2018
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Issue:

When opening Agile Designer, the Toolbox Dock is not visible. It was previously there in the product, but now it is no longer visible. How I can retrieve or reset this? 

Environment:
CA Agile Requirements Designer (ARD)- Agile Designer
Cause:

Sometimes you can lose the Toolbox Dock if you have double clicked on it so it pops out of the main ARD GUI. If you double click on the Toolbox Dock window, it will return to no longer being a separate window. In rare cases, the Toolbox Dock might be accidentally removed completely by a user. The steps below show how to resolve this. 

Resolution:

Here is how to normally pop out and return the Toolbox Dock window:

Click the windows icon to make the Toolbox Dock a separate window. 

pop out toolbox.png

When the Toolbox Dock is in a separate window, double click on it to return it to the ARD GUI.

now toolbox is separate window.png

 

If you no longer see the Toolbox Dock at all, even after restarting ARD, you will need to edit the Windows registry. Agile Designer saves color schemes and styles in the registry, which includes the Toolbox Dock. 

NOTE: Please take a backup of your Windows registry before making any changes to it. 

Steps to edit the Windows registry and return the Toolbox Dock to ARD:


1. In the Window's search, type in 'regedit' and Enter to launch the Registry Editor. 

regedit search.png

2. Locate this Registry key on the left pane: HKEY_CURRENT_USER\Software\CA Technologies\AgileDesigner

registry edit file path.png

 

3. In the right pane, look for the 'state' entry and delete it. 

delete state.png

4. Also, delete the 'geometry' entry from the right pane. 

delete geometry.png

5. Restart Agile Designer and the VM/Server where the registry edit was made. 

6. The next time ARD is launched, it should go back to the default settings and the toolbox should be visible.

toolbox dock.png

Additional Information:

If you experience any further issues, please open a support case by going to https://support.ca.com/us.html or https://www.ca.com/us/services-support/ca-support/contact-support.html.