Not able to open a scheduled report in PDF format out of CABI4.1

Document ID : KB000044623
Last Modified Date : 14/02/2018
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Issue: 

When checking a scheduled report result in PDF format out of CABI4.1 via the “History” option we get either a blank browser result (Firefox) or an error message (IE and Chrome):

Error here java.lang.RuntimeException: org.apache.jasper.JasperException: java.lang.NullPointerException: while trying to invoke the method com.crystaldecisions.report.web.viewer.CrystalReportViewer.processHttpRequest(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse, javax.servlet.ServletContext, java.io.Writer) of a null object loaded from local variable 'htmlViewer'…

Opening the actual PDF document outside of the “BI Launchpad” is working.

Environment:  

Spectrum 10.0, 10.1, 10.1.1 with CABI4.1

Cause: 

The folder structure of the standard reports (Alarm, Activity, Asset, ...) is not matching internally with the path to the PDF document and CABI/BOXI has therefore issues to open the PDF document out of the “History” option in scheduled reports.

Workaround:

We can suggest two workaround options for generating the PDF report out of the “BI LaunchPad”:

1. Setting the “Destination” as file system and provide the directory name while scheduling the report.

2. Use the “Destination” as BI Inbox and schedule the report. (Access the report via the “Home” tab, as opening the PDF out of the “Home” tab is working)

We have identified the root cause of the problem and changes should be done on the core side and addressed in the upcoming Spectrum version 10.2.

Additional Information:

Spectrum 10.2 is scheduled for the end of the second half of 2016.