No sites are available after install of RA/NFA. If IIS Manager GUI is observed, Default Web Site is empty.

Document ID : KB000020338
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

After the install of RA/NFA, RA admin page will not be opened, this is because there are no web sites created under IIS sites section.

Solution:

Follow the below steps inorder to resolve the problem:

All web sites' information is stored under "<configuration><system.applicationHost><sites>" in the ApplicationHost.config file(%windir%\System32\InetSrv\config). Once the section of default website is corrupt, IIS manager will fail to show the default website. The ApplicationHost.config file will not be clear up/removed during IIS reinstallation. Hence, your default website seems to be missing all the time.

To solve this issue, please try the following steps

  1. Back up both your files in the directory of " %windir%\System32\InetSrv" and "%SYSTEMDRIVE%\inetpub"
  2. Uninstall IIS
  3. Uninstall Windows Process Activation Service(Server Manage->Remove features), this will remove the ApplicationHost.config file and other files in the directories mentioned in step 1.
  4. Reboot system, reinstall IIS

If the above step doesn't resolve the problem, you need to add "Default Web Site" Manually.

Follow the below steps to add Default Web Site.

Open IIS Manager,
Right click on Sites -> select "Add Web Site" option -> Enter web site name as "Default Web Site" -> Select Application pool as "DefaultAppPool" from drop down -> Click on "ok"
Enter Physical path as "C:\inetpub\wwwroot"
Also add the below bindings by selecting Add option one by selecting one binding at a time.

After this, try to install NFA/RA.
Websites should be updated properly now.