No notification email received when the MAM app is published

Document ID : KB000029447
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem

After making all required configurations and publishing the MAM app the notification email was not sent to the defined email address

The following is seen in the ca-notify.log on the MAM server

2015-01-16 07:14:55,130 [NotifyHandler,pool-30-thread-6] WARN - TID[0|1|1|litri01-U137520-56609:1:230] 2751106: Email Address 'test1@emmlabuk.local' does not meet requirements for message type MAMNotificationForDownload

Environment

  • CA Mobile Application Management 14.4
  • SQL server 2012

Cause

The Regular Expression defined in the MAM notifications table (MCC_NOTIFY) for validating the email addresses was configured to allow only email addresses *.ca.com

Solution

Servers upgraded from previous release

Run the following SQL queries

  • DELETE FROM MAM_ACCESS_POLICY WHERE STATUS='D';
  • DELETE FROM MAM_POLICY_DATA where state=0;
  • UPDATE MCC_NOTIFY_TYPE SET ADDRESSING_PARAM='\b[\p{Alnum}._%+-]+@(?:[\p{Alnum}-]+\.)+[\p{Alpha}]{2,6}\b' WHERE NAME IN('MAMNotificationForDownload','MAMNotificationForAllow','MAMNotificationForDeny','MAMNotificationForJailbreak');

Newly built 14.4 servers

Run the following SQL query

  • UPDATE MCC_NOTIFY_TYPE SET ADDRESSING_PARAM='\b[\p{Alnum}._%+-]+@(?:[\p{Alnum}-]+\.)+[\p{Alpha}]{2,6}\b' WHERE NAME IN('MAMNotificationForDownload','MAMNotificationForAllow','MAMNotificationForDeny','MAMNotificationForJailbreak');