DE353011 No metrics shown in USM from logmon probe using nimqos

Document ID : KB000094096
Last Modified Date : 21/05/2018
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Issue:
Qos generated by nimqos cannot be seen in USM 
Qos is seen in SLA 

Issue can be reproduced easily in lab 
  1. create qos definition 
    • nimqosdefinition -q test-string -d "test-string" -g test -u Percent -s % 
  2. create qos metrics 
    • nimqos -q QOS_TEST-STRING -s "<ip address>" -t "TEST-STRING" -v 10.75 -i 1800 -T "5.15" -N "TEST-STRING" -M "5.15:1" -R "<ip address>" 
Environment:
UIM 8.51 SP1
Cause:
INVESTIGATION 
----------------- 
on examination there is no entry in CM_CONFIGURATION_ITEM_METRIC. 

.met file is crated in robot niscache 
data_engine successfully process the qos definition and creates entry in S_QOS_DEFINITION 
data_engine successfully process the qos messages and data is seen in SLA and S_QOS_DATA 
ci_metric_id (MDBE7FCA725A8A0903CA99034A243F234) in S_QOS_DATA is not found in CM_CONFIGURATION_ITEM_METRIC 

following is seen in discovery_server.log 

16 Mar 2018 15:56:52,002 [NisImportDispatcher-3] WARN com.nimsoft.discovery.server.ec.importer.MetricImporter - Skipping import of metric with missing parent CI: CmMetric{ metId=MDBE7FCA725A8A0903CA99034A243F234 ciId=C5A5E0F1B5A6DDCCC4CD56D8260BF5C0A type=5.15:1 }
Resolution:
  • A fix is available for this upon request from CA Support
  • Please log a support case and request the fix for DE353011