No Memory usage data for the Virtual Machines

Document ID : KB000008044
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

The Virtual Machines running in Hyper V do not display Memory Usage (%) as below:

1.jpg

 

Environment:
All releases of Spectrum running on supported Platforms
Cause:

The Virtual Machines table is defined in the $SPECROOT/ tomcat/webapps/spectrum/WEB-INF/vhm/config/ table-systemedge-hypervaim-virt-machines.xml file.

The Memory Usage (%) column is defined in this file as follows:

    <!-- hypervAimStatVMMEMUsage -->

    <column>

    <name>com.aprisma.spectrum.app.vhm.common.hyperv.hypervAimStatVMMEMUsage</name>

    <content>

        <attribute>0x56e05c6</attribute>

    </content>

    </column>

 

The 0x56e05c6 attribute is the hypervAimStatVMMEMUsage attribute from the caHyperVAimMib at oid 1.3.6.1.4.1.546.16.56.2.2.2.1.22 so it is read directly from the device.

 

 

The cause of the issue is OID 1.3.6.1.4.1.546.16.56.2.2.2.1.22 is not providing the data. To confirm the same follow the below steps:

1. Query the OID 1.3.6.1.4.1.546.16.56.2.2.2.1.22 using MIB Tools as follows:

-> From Spectrum OneClick Console select Tools -> Utilities -> MIB Tools...

-> From the MIB Tools Console -> Under Contents Pane, type Hyper-V Manager IP Address under Device, Select appropriate SNMP version and SNMP Community String -> Click on Contact

-> Now, under Hierarchy, in Device Search, enter the OID 1.3.6.1.4.1.546.16.56.2.2.2.1.22 -> Click on Next 

-> Now select hypervAimStatVMMEMUsage -> perform SNMP get request by clicking the Camera icon (3rd Option under Hierarchy) as shown below:

3.JPG

-> Click on OK as below:

4.JPG

2. Now, check the Results, if you see the values as below, this would mean Spectrum is not receiving the Memory usage data from the MIB:

 

2.jpg

 

Resolution:

-> Spectrum is only displaying the data it is receiving from the OID 1.3.6.1.4.1.546.16.56.2.2.2.1.22

-> The agent is not providing the data

  • Try recycling the sysedge agent service

-> If the problem still persists then open a ticket with CA Support under CA Virtual Assurance Infrastructure Manager (VAIM) product for further troubleshooting.

 

Additional Information:

For further reading:

https://docops.ca.com/ca-spectrum/10-2-1/en/managing-systems/virtual-host-manager/microsoft-hyper-v