No default value applied for features configuration in Policy Server Configuration Wizard

Document ID : KB000008012
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

We are installing Policy Server and when running the Configuration Wizard from the command line (using the "-i console" parameters) at the "Choose Features" menu, there is no default value applied:

Choose Features
---------------

Choose which features you would like to configure.

1- OneView Monitor GUI
2- Web Server(s)
3- SNMP
4- Policy Store
5- None of the above

ENTER A COMMA-SEPARATED LIST OF NUMBERS REPRESENTING THE
DESIRED CHOICES, OR
PRESS <ENTER> TO ACCEPT THE DEFAULT:

The wizard in console mode does not tell which is the default value (1, 2, 3, 4 or 5), and because of this, we were not able to configure Session Assurance as it doesn’t ask for Master Key, as we accepted the default. I understand we should have picked the option 5 instead, but the documentation does not mention we have to select it:

Enable the Advanced Authentication Server

Enable the advanced authentication server as part of configuring your Policy Server.

Follow these steps:

1. Start the Policy Server configuration wizard.
2. Leave all the check boxes in the first screen of the wizard cleared.
3. Click Next.
4. Create the master encryption key for the advanced authentication server.

Note: If you are installing another (nth) Policy Server, use the same encryption key for the Advanced Authentication server that you used previously.

5. Complete the rest of the Policy Server configuration wizard.

The advanced authentication server is enabled.

(Extracted from Policy Server Installation Guide 12.52 SP1)

Environment:
Policy Server R12.52 SP1 CR00 on SunOS 5.10 SPARC
Resolution:

This issue is fixed in R12.52 SP1 CR06, as the option "None of the above" is the default option to make sure that the operator doesn’t miss the additional configuration options even if they don’t select any:

 

00103617 DE106225 During Policy Server installation in console mode, Policy Server configuration wizard does not point to the default value in the Choose Features menu.

https://docops.ca.com/ca-single-sign-on/12-52-sp1/en/release-notes/cumulative-releases/defects-fixed-in-12-52-sp1-cr06

Additional Information: