NM Gateway Server service fails to start with error code '1062'

Document ID : KB000007402
Last Modified Date : 14/02/2018
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Issue:

When trying to start a CA Automation Point Service from the Configuration Manager -> Expert Interface -> Infrastructure -> Services panel the following error message can be seen:

CapSvcs::StartASOService -> Function = 'ControlService' failed with error code '1062'

Reason = The Service has not been started.

Failed to start service = 'CA-AP NM Gateway Server’

 

 

In ASOTRACE.log following message can be seen:

09:14:59.673 S0 P10596 T9796 C=2  Sev=E JNIDLL::NmGatewaySrv.rmiRegister> Unable to register NM Gateway Server with RMI. Shutting down.

 

Environment:
MS Windows Server
Cause:

Local Java policy does not grant permission for communication via the NM Web Gateway service port.

Resolution:

(1) Go to installation directory of your 32bit Java installation (typically C:\Program Files (x86)\JAVA\<jdk\jre version>).

(2) Find java.policy file inside the lib\security subfolder and back it up.

(3) Open the java.policy file and add following lines at the end of the file:

grant {

    permission java.net.SocketPermission "localhost:5099", "listen";

};

 

Note: if you are not using the default NM Web Gateway port 5099, use the number of the used port instead of the 5099.