Nimsoft robots are showing Loop Back IP address

Document ID : KB000046010
Last Modified Date : 14/02/2018
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Issue: 

Robots are showing in USM/UMP with the loop back address 127.0.0.1 when we expect to see their actual server IP.

 

Environment:  

This issue was found in UIM 8.31 but the resolution is general information applicable to most versions of UIM.

 

Cause: 

The robot.cfg file did not have any entries for robotname or robotip.

 

Resolution/Workaround:

1. RDP to robot server

2. using the Nimsoft Service Controller, shutdown the UIM service 

3. edit the robot.cfg file so that these fields are filled in appropriately: 

robotname = 

robotip = 

4. using the Nimsoft Service Controller, start the UIM service 

5. allow some time to pass (up to an hour or so) and check to see if the issue remains 

 

Additional Information:

 

If you are using Nimldr, robot communication over the network can fail due to an invalid /etc/hosts file. If this occurs, ensure that the /etc/hosts file on any system hosting a UIM robot, hub, server, or UMP instance contains a valid entry for the local system. This must be a fully qualified hostname and IP address. If only loopback is defined (for example, localhost 127.0.0.1), then the controller probe on that system will be unaware of its own IP address, resulting in network communication failure.

See here - https://docops.ca.com/ca-unified-infrastructure-management/8-4/en/upgrading-release-notes/known-issues#KnownIssues-RobotCommunicationFailureonUnixWhenUsingNimldr