Nimsoft Robot installation launch issue

Document ID : KB000124613
Last Modified Date : 04/02/2019
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Issue:
While launching the UIM Nimsoft Robot installation or the Infrastructure Manager on Windows Server 2008 Standard SP2 64-bit, we are getting a class not registered error.
Environment:
- Robot version 7.80 
- Windows server 2008 Standard 6.0.6002 Service Pack 2 Build 6002
- Most current Windows updates had not been applied
Cause:
- Corrupt/Non-updated Windows OS build
Resolution:
  • The most common cause of a class not registered error is a dependency on Visual C++ 2005 or 2008 runtime DLLs. Under Control Panel, check to make sure that these packages are installed.
  • Ensure that user running the installation (NimBUS Manager.exe) has local Windows administrator rights or try running the install as the Windows Administrator
  • Try temporarily disabling Anti-Virus and rerun the install. AntiVirus has been known to interfere with installs in some cases.
  • Verify that the 'Windows Installer' Service is has not been disabled on the system.
  • Make sure that Windows User Account Control (UAC) is not interfering with the robot install on this system. UAC could be disabled but this is not recommended as a permanent solution. Instead, make sure that UAC is configured to allow the user privileges to register DLLs required to run the install
  • Try installing on another machine running Windows server 2008 Standard SP-2 64-bit
  • Try installing on another machine running Windows server 2008 R2 (non-Standard build)
  • Determine or ask the customer whether or not the machine is a hardened system, e.g., security software other than AV, or limited OS footprint, group policies, account policies, etc...
  • Machine rebuild/New VM
  • Check that there are no missing or corrupted .dlls (that perhaps InstallShield is trying to reference)
For example:
2019-01-17 09:11:13, Info                  CSI    000002ca [SR] Beginning Verify and Repair transaction
2019-01-17 09:11:14, Info                  CSI    000002cb [SR] Repairing corrupted file [ml:520{260},l:144{72}]"\??\C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\v3.0"\[l:60{30}]"PresentationFramework.Aero.dll" from store
2019-01-17 09:11:14, Info                  CSI    000002cc [SR] Repairing corrupted file [ml:520{260},l:144{72}]"\??\C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\v3.0"\[l:34{17}]"System.Speech.dll" from store


- open a command prompt on the machine and run this command:
   sfc /scannow

When it completes (it may take some time), check out the output which will show any missing/corrupted dlls and whether or not they were repaired.
Additional Information:
Customer may choose to download this utility called Revo Uninstaller Pro https://www.revouninstaller.com/revo_uninstaller_free_download.html you have to get the "Pro" version which is a 30-day free trial (the "Free" version will not work.) Install this on the customer's machine. If necessary, you can delete it once you collect the information. Once it is installed, open it up and you can right click on the NimBUS Robot.exe in C:\Program Files (x86)\Nimsoft\install\setup and there will be a popup that says "Install with Revo" and you click that, and it will create a very detailed log of everything the installer does.

After it fails you should be able to inspect the Log. You have to stop the Revo and save off the log, then go into Edit Log and you will see the Properties, Registry Items and Files and Folders. You will probably see where it quits as well, e.g., output which also shows the temp directories its acting upon , e.g., C:\Users\<username> for instance, as well as .dlls it is using.