Nimsoft on Demand (NoD) Relay hub connection and queue issues

Document ID : KB000034294
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem: 

1) Queues building in size.

2) Cannot open NoD Relay node (in IM) from the Cloud

In IM on the NMS-Server in the cloud, you cannot open the NoD Relay node and expand the tree to see the probes.  Plus, although the node may be green, once you click on it, it turns red. On a local IM session on the NoD relay the problem was intermittent. On the NMS-Server it never worked. Note also that in this scenario, Tunnel operations were unaffected.

Environment:  

UIM Server:  7.6 and later
Nimsoft On Demand (NoD)

Cause: 

1.  Post queues do not guarantee delivery of messages.  For guaranteed delivery of messages you must use get/attach queues.

2.  IM may try to use a port that can be assigned to another probe when tunnels are configured to use the first probe port setting from the controller.  When this occurs, it is not possible to access a relay hub from IM.

Resolution:

1) Queues building in size

In this case solution was to change from using post queues to get/attach queues.

2) Cannot open NoD Relay node (in IM) from the Clou

On the NoD Relay, open the hub probe, click on the Hubs Tab, expand the Source column for the NOD Relay, and notice the port column and value which is usually adjacent to it.  If you see a port in the range of 48000, under Tunnels->Advanced Tab, set the Tunnels to "Ignore first probe port setting from controller" and use another port instead, e.g., 50000 (First Tunnel Port setting).  This port does not need to be open on the firewall, it is just the communications port.  Once these changes are made and the hub is restarted, you should be able to open the NoD Relay node and expand the tree and it should no longer turn red.