Nimsoft alerts not displayed on the SOI console

Document ID : KB000008040
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Nimsoft alerts are not displayed on the SOI console

Environment:
Nimsoft Connector 3.7.0.5UIM 8.5SOI 4.0
Cause:

The UIMconnector.log contains

 

WARN [ModuleErrorListener: CA:00050_<nodename>] controller.AlarmSubscriber - Unable to get primary NAS port. Alarm clearing functionality disabled
WARN [ModuleErrorListener: CA:00050_<nodename>] controller.AlarmSubscriber - Unable to get secondary NAS port. Alarm clearing will be disabled during hub failover

WARN [ModuleErrorListener: CA:00050_<nodename>] controller.AlarmSubscriber - Unable to empty alarm message catalyst queue: permission denied

 



 

 
Resolution:

Reset the Nimsoft hub user password, encrypt it on the connector machine as follows

CD to the ..\CA\Catalyst\CatalystConnector\tools\encrypt\ at a DOS command prompt and
run

encrypter.bat <new_password>

Copy the result.

Stop the Catalyst Container service


Edit the

..\CatalystConnector\registry\topology\physical\<nodename>_CatalystConnector\modules\configuration\Nimsoftconnector.xml file

Update the property below with the result of the encrypter command

<property name="hubPassword" value="<newencryptedpassword>

Delete all files in the folders below

\Catalyst\CatalystConnector\container\nls_store
\Catalyst\CatalystConnector\container\registry-cache (this is on the shared cluster drive if I remember correctly)


Restart the Catalyst Container service

 

, update the hubPassword property in the nimsoftconnector.xml configuration file with the new encrypted password.