Nimsoft agent goes down intermediately

Document ID : KB000100922
Last Modified Date : 15/06/2018
Show Technical Document Details
Issue:
We are using nimsoft agent to monitor server. We have observed in many servers nimsoft service controller status information does not show and all the operational buttons gets disabled. due to this we get false alert and it generates ticket in service desk. We are losing score in our SLA due to false alerts.
Environment:
Windows
UIM 8.51
Robot | Hub - 7.80
Cause:
Looking at controller.log, as we can see for every few minutes the Robot is losing communication with Hub and it failed to connect on hub ports... 

Jun 6 15:23:13:812 [10820] Controller: hub My_hub(10.10.10.10) NO CONTACT (communication error) 
Jun 6 15:24:14:192 [10820] Controller: hub My_hub(10.10.10.10) NO CONTACT (communication error) 
Jun 6 15:25:01:196 [10820] Controller: async_req - nimSessionAConnect failed for 10.11.11.11/48001 (error) 
Jun 6 15:25:01:196 [10820] Controller: async_req - nimSessionAConnect failed for 10.11.1.11/48007 (error) 

Due to this communication problem, the Nimsoft Service Controller status fluctuates, also telnet from Robot to Hub fails for every few minutes and then it connects.User-added image
 
Resolution:
From the above symptom as telnet fails to connect to Hub, this appears to be an Environment problem.

1) We could disable Anti-Virus application for few minutes and check telnet works without any disruption
2) Run wire-shark trace to see the connectivity issues between Robot to Hub
3) Reboot the robot machine due to Port Exhaustion

After rebooting the Robot server, now it started working and found no more disconnect issues between Robot to Hub