NFA Data Sources Synchronization fails in CA Performance Management

Document ID : KB000124288
Last Modified Date : 09/01/2019
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Issue:
A CA Network Flow Analysis (NFA) Data Source was added to CA Performance Management (CAPM). In the CAPM CA Performance Center (CAPC) web UI it shows as Red with Synchronization failures.
Environment:
All supported CA Performance Management releases
Cause:
The following error is observed in the (default installation path) /opt/CA/PerformanceCenter/DM/logs/DMService.log.

ERROR | pool-2-thread-10 | 2019-01-08 07:29:40,354 | com.ca.im.portal.dm.productsync.DataSourcePoller 
Data source Network Flow Analysis@<NFA_HOST> encountered an error while processing a sync request. The problem is in the data source, not CAPC. Check the logs for the data source to determine the cause of the problem. The following stack trace shows the context of the sync request: 
java.lang.IllegalArgumentException: Data source 4 is missing 1 binding group references in the bind_users table 

This is due to the PermissionItemID value from NFA not being synchronized to CAPC for one or more users in the bind_users table.

In this case a default NFA system user, nquser, was missing this value. Other users had it set properly. The users with the problem were identified by running this query in the PC netqosportal MySql DB:
 
select * from bind_users\G;
Resolution:
In the MySql prompt on the NFA server, in the reporter database run the following:

select * from user_definitions where username = 'NameWithNULL_in_bind_users'\G; 

In the MySql prompt on the PC server, in the netqosportal database run the following: 

update bind_users SET PermissionItemID = <ID> where UserName = '<userName>'; 

After this the NFA Data Source synchronized successfully.