NFA 3 to 2-Tier Migration will not execute

Document ID : KB000008420
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

You may have issues executing the PowerShell script "3Tconverter.ps1".

"File 3Tconverter.ps1 cannot be loaded.  The file is not digitally signed.  The script will not be executed on the system."

Environment:
NFA 9.3.3 / 9.3.6 / 9.3.7Windows Server 2008 /2012Redhat Linux
Cause:

For some reason the script is not being trusted by your system. It may be because of the way it was copied over.

Resolution:

From the PowerShell window, instead of using "Set-ExecutionPolicy RemoteSigned" as recommended in the mmigration guide, use this command instead:

 

"Set-ExecutionPolicy Unrestricted"

 

(Enter Y when prompted).

Now you should be able to execute the script as it is not doing certificate checking.