New Procedure to Upgrade CA XCOM Data Transport for Linux PC 11.6 SP01 from CA XCOM Data Transport for Linux PC 11.6 SP00

Document ID : KB000009765
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

Please read the XCOM for Linux PC Release 11.6 SP01 cover letter for an overview of this upgrade.

  • You can now perform an upgrade from 11.6 SP00 which migrates all your your settings and files. It doesn’t require you to reboot the server after the install which was previously required.  
  • New enhancements also include TLS V1.2 support

Installation of CA XCOM Data Transport for Linux PC X64 requires both of the following: 

  1. Redhat Enterprise Linux, or SUSE Linux Enterprise running on an Intel or compatible PC
  2. Kernel level at Version 2.6.32 or higher
  • You can upgrade CA XCOM Data Transport for Linux PC from Release 11.6 64-bit to Service Pack 11.6.01 64 bit. 
  • The CA XCOM Data Transport for Linux Service Pack 11.6.01 installer acts as both a new and an upgrade installer. If the Installer does not find any installed XCOM instance on your computer, the installer acts as a new installer. If the installer finds a Release 11.6 XCOM instance, the installer acts an upgrade installer.
Instructions:

Here are the steps to download r11.6 SP01: 

• Login to http://support.ca.com
• Go to Download Center -> Download Products
• From “Select Product” dropdown, Select Product Name. (ex: XCOM Data Transport for Linux PC - LINUX -ALL)
• Select r11.6 from “Select Release” dropdown.
• Select SP01 from “Choose Gen level” dropdown and click on GO.
• Download ISO image for CA XCOM Data Transport for Linux PC r11.6 SP01 - Product Package DVD10172026E.iso

Here is the Overview for the XCOM for Linux PC 11.6 SP01 upgrade from XCOM for Linux PC 11.6 SP00: 

When you run the installation program to upgrade the product, the program performs the following tasks:

  • Performs pre-installation checks to verify the following criteria:
  • The user who invokes the installer has root permissions.
  • No CA XCOM Data Transport processes are running.
  • The currently installed product version is a candidate for the upgrade process.
  • Backs up the XCOM_HOME directory from the existing product environment.
  • Removes existing XCOM Service Pack 11.6.00 and CAPKI software
  • Installs the following entities:
  • CA XCOM Data Transport binary files and services
  • CAPKI
  • Restores the existing CA XCOM Data Transport for UNIX/Linux user customized settings:
  • User customized configuration files, including configssl.cnf, history.inserts, log4j.properties, StandAloneGUIParameters.xml, xcom.cnf, xcom.glb, xcom.ses, xcom.tid, xcom.log, xcomlp, xcomntfy, txpi files (Linux only), and exit scripts
  • User customized configuration folders, including ssl, tmp, preferences, trace, and convtab
  • Copies the user specified JDBC driver jar files to the XCOM_HOME/lib directory.Performs configuration file migration where the key value pair are compared and merged in configuration files such as xcom.glb, xcom.cnf, and configssl.cnf.
  • Migrates the history database schema from Release 11.6 to Service Pack 11.6.01.
  • Migrates the Transfer Queue records from Release 11.6 to Service Pack 11.6.01.
  • Performs post-installation tasks.
Additional Information:

Go to our docops site for more in depth about the Upgrade from release 11.6 and a video.

If you are currently using XCOM r11.5, you can refer to this documentation Upgrade from Release 11.5 for details on how to upgrade to r11.6 SP01. 

If you are not registered on our site, support.ca.com, please follow these steps to register:

  1. Go to support.ca.com and click on Register 
  2. Fill out the form, making sure to select "Enterprise Support Access" on the "Support Access Information" section of the form. 
  3. Enter your siteid in the "Enterprise Site ID" - very important
  4. Fill out the rest of the form
  5. Submit 
  6. You will not be registered immediately. Wait for an email confirming your registration.

NOTE: At the time this tech doc was originally written, XCOM for Unix 11.6 SP01 (AIX, etc.) was not available yet, but became available on 2/7/2017.