New Certifications fail to import for new Device Pack

Document ID : KB000045045
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem:

Unable to install or import new Vendor Certification (VC) and Metric Families (MF) into the Data Aggregator (DA) after installing a new Device Pack (DP) for the CA Mediation Manager (CAMM) product.

 

Affected Configurations:

Upgraded CAMM installations that run release r2.6.0

 

Cause:

Using the OpenJDK Java version instead of correct Oracle Java JDK on the CAMM server operation system.

When OpenJDK is in place it allows a user to be configured in CAMM the first time. If a different user is needed, the change is made in the CAMM UI, but due to problems with OpenJDK the change is never populated in the /opt/CA/CAMM/MC/productinfo.properties file where it is read from. Thus the wrong user continues to be used despite the correct user showing as configured in the UI.

 

Solution:

OpenJDK Java versions are not recommended or supported for use with CAMM. Only Oracle Java JDK releases should be used. To work around the problem until a new Java version can be put installed on the server:

- Update the configuration as would be done normally through the UI

- Restart the CAMM web services using the commands:

Stop CAMM Web Server: /opt/CA/CAMM/tools/stopall -c web

Start CAMM Web Server: /opt/CA/CAMM/tools/startall -c web 

 

Confirm the user is updated in the /opt/CA/CAMM/MC/productinfo.properties file.