New CABI component is not working on new install

Document ID : KB000004551
Last Modified Date : 21/09/2018
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Issue:

When accessing the URL for the CABI server, we receive a 404 error. In the cabi logs we see the following:

Oct 19 09:21:58:522 [UserSynchronizationThread, cabi] JasperUserUtility:login(): URL attempted :http://192.168.1.1/cabijs/login.html
Oct 19 09:21:58:522 [UserSynchronizationThread, cabi] JasperUserUtility:login(): Response code :404
Oct 19 09:21:58:522 [UserSynchronizationThread, cabi] UimToJasperUserSync(): I can't log into CABI! I've tried all the known passwords. I give up...

Environment:
Windows
Microsoft SQL Server
Bundled cabiĀ 3.00
Cause:
This will happen if the superuser password was changed or corrupted.
Resolution:
  1. Delete the cabi probe and wasp in Admin Console 2 from the robot on which cabi is installed.
  2. On the filesystem of the cabi robot delete the following:
    1. <nimsoft home>\cabi
    2. <nimsoft home>\probes\service\cabi
    3. <nimsoft home>\probes\service\wasp
  3. On the UIM database drop all the tables that CABI puts down to start fresh (sql script attached)
  4. Reinstall CABI
Additional Information:

drop_cabi_tables.sql


CABI installation documentation

File Attachments:
TEC1183173.zip