MSP Error: 'We're sorry. There seems to be a problem with this file' due to issue with Notes

Document ID : KB000091838
Last Modified Date : 08/05/2018
Show Technical Document Details
Issue:
In the Microsoft Project (MSP) New Driver, receive an intermittent error message: "We're sorry. There seems to be a problem with this file that keeps us from opening it. Please try using a backup copy if available." In reviewing the XML associated to the project, it shows that the issue appears to be due to Notes being corrupted upon export from PPM, where characters are incorrectly appended to the end of Notes tags. This is more consistently reproducible as the number of tasks with large text notes in the project increases.

STEPS TO REPRODUCE 
1. In MSP create a new project 
2. Create one new task with a Start and Finish Date 
3. Double click on the task 
4. Click on the 'Notes' tab 
5. Paste a large quantity of text into the Notes field (Such as 3,000 characters or more) and click OK 
6. From the CA PPM Integration tab, click the Save As button to save the project to PPM as a new project 
7. Attempt to open the project from PPM to MSP 
(Note if you do not receive the "We're sorry error at this step, repeats steps 2-7 above until the error is generated) 

Expected Results: The project opens successfully with task(s) displayed 
Actual Results: Receive the following MSP error and the project does not open. "We're sorry. There seems to be a problem with this file that keeps us from opening it. Please try using a backup copy if available." Additionally, if you look at the XML, unexpected characters are randomly added to the end of notes tags. 
Environment:
This issue applies to CA PPM 15.2, 15.3, and 15.4 MSP New Driver
Cause:
This is caused by DE39765
Resolution:
This issue is tentatively scheduled to be fixed in CA PPM 15.4.1. 

Workarounds: 
Option 1: Sometimes, making a change to the Note in PPM, such as removing a '.' at the end of a line in a note that has corruption in the tag helps, but in some instances it keeps coming back. 
Option 2: If the above that doesn't help, as a temporary workaround, reducing the number of notes in the project has helped to allow the project to open. The Notes information can be stored locally in a document until the issue is resolved where the Notes can then be added back to the tasks. 
Additional Information:
Reference KB000071385 - CA PPM and MSP integration - List of Knowledge Documents
Reference KB000015956 - CA PPM and MSP integration known defects - Support Technical Document Index
Reference KB000004116 - Special characters in Task Name, Task Notes, and Charge Codes have entire entries removed from project when opening project with MS Project with New Driver or the project opens with an error.