MQ Agent not showing "Message Flow State" metric

Document ID : KB000112354
Last Modified Date : 28/08/2018
Show Technical Document Details
Issue:
Not able to monitor the "Message Flow State" metrics when enabling inside MQ properties.
Environment:
WebSphere MQ Version: 7.0.1.14
ON AIX 7.1 64-bit
WebSphere Message Broker version 7008 Level: S700-FP08
PowerPack MQMonitor from 9.7 afterwards.
Resolution:
1) Open your "MBMonitor_7.properties"

2) Search for "[brokerName].executiongroup", it should be under below section:

##
## Execution Group 
##

# List the Execution Groups for which statistics data needs to be collected.
# Remember to use the same Broker Identifier you have mentioned in 
# the 'mq.broker.monitor.list' property for all the settings mentioned in the
# following section. 
# value 'all' will be assumed by default
# Use the broker identifiers mentioned in the mq.broker.monitor.list to configure the property as shown in the following examples
# eg.
# a.executiongroup = all
# b.executiongroup = ExecutionGroup1,ExecutionGroup2

#[brokerName].executiongroup = SDA_001,CORE_003,CRM_001,SPU_001,BEL_001,MHOST_001,CORE_CPRE,CORE_SDA,EG_SRV_05,EG_SRV_15,RM_001,EG_SRV_03,EG_SRV_18,EG_SRV_02,PAYPAL_001,ESOL_001,ADQ_001,CORE_IVR,SPUCLI_001,CORE_001,SPUCLI_002,EG_SRV_09,ARQ_001,EG_SRV_06,EG_COREIN_01,EG_CORE_01,EG_SRV_21,EG_COREAUDIT_01,EG_SRV_07,EG_SRV_04,CORE_002,EG_SRV_13,EG_SRV_16,TLS_001,HPC_001,GAD_001,SPU_003,CAM_001,TLS_002,EG_SRV_01,CORE_ATM,SPU_005,SPU_004,EG_SRV_17,SEG_001,ATM_001,SAT_001,SPU_002,CRM_002,SPU_007,EG_SRV_22,MHOST_002,CORE_BPI,SDA_AUDIT,CORE_004

[brokerName].executiongroup = all

3) Make sure that "[brokerName].executiongroup = all" is commented.

4) Restart the application.
Additional Information:
Fur further troubleshooting MQ Agent troubleshooting, please read:

https://comm.support.ca.com/kb/mq-agent-configuration-tips/kb000103872