Moving autosys agent and the old SAP 3.2 sp1 adapter from one HP/IA 64 server to another newer one. The old, original server is running version 4.5 of the autosys agent and version 3.2 sp1 of the SAP adapter. The new server is running version r11.

Document ID : KB000045890
Last Modified Date : 14/02/2018
Show Technical Document Details

Introduction: 

Moving autosys agent and the old SAP 3.2 sp1 adapter from one HP/IA 64 server to another 

newer one. The old, original server is running version 4.5 of the autosys agent and 

version 3.2 sp1 of the SAP adapter. The new server is running version r11.0 sp5 of the 

autosys agent and version 3.2 sp1 of the SAP adapter. 

 

I have already installed the new agent and SAP adapter on the new server. I need to 

duplicate the SAP adapter configuration on the new server so it is the same as on the

old server. 

 

Can you tell me which configuration files to copy from the old server to the new server in order to accomplish this ? 

 

 

Question: 

Can you tell me which configuration files to copy from the old server to the new server in order to accomplish this ? 

 

Environment:  

SAP 3.2 sp1 adapter

 

Answer: 

Install on your clean test machine where no /opt/CA exists the Autosys agent. Then create a tar file from this so that you

have an install image only for the autosys agent.

 

Then install the SAP Adapter also into /opt/CA and go through the installation steps until everything is installed,

please note that the librfccm.so needs to be accessable for the installation. Then create a tar file from the /opt/CA where

you now have both the Autosys agent and the SAP Adapter installed in the same path.Then you can copy/install onto

your machines which ever version of the installation you require.

 

Please also note that you will have to run the auto_install for the autosys agent after restoring onto your appcom

machines also you will have to reconfigure the SAP Adapter for the SAP system that it will be connecting to. I would also

check that the librfccm.so is also in the correct place and that the links in /opt/CA/CAlib are pointing to the correct binaries.

 

One additional step though, etc/auto.profile will need to be updated on the target machine. Copy the bottom section of

the /etc/auto.profile from the source into the target machine's auto.profile. (it's clearly marked which part is for

the SAP adapter.