Moving an agent from one scalability server to another takes a long time.

Document ID : KB000025873
Last Modified Date : 14/02/2018
Show Technical Document Details

Symptoms: 

It takes a long time when we move an agent from one scalability server to another.
Prior to the release of 11.2 C3 this was a quick process, but now it usually takes up to 24 hours.

 

Environment:  

Client Automation agents (on any platform) 

 

Cause: 

Reregistration is scheduled to occur only once a day by default

 

Resolution/Workaround:

The agent automatically reregisters with the domain manager according to the scheduler as contained within the policy settings under

DSM->common components->CAF->Scheduler->Registration refresh scheduled job.

Figure 1

This defaults to 1 day.

To have it run every 8 hours instead of once a day, you would need to modify the following policy settings:
Caf Scheduler: Type of Job: now hour random_minute
Caf Scheduler: Repeat number: 8

This would cause all agents to reregister after a random minute interval every 8 hours.

It would cause any change of scalability server to occur within 8 hours maximum instead of 1 day.