Issue:
The PPM Webservice InvokeAction Response is missing the <returnValue>false</returnValue> tag. When a PPM Webservice call is used to invoke a Clarity process, the Webservice InvokeAction Response should appear as:
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
<soapenv:Header/>
<soapenv:Body>
<ProcessResult xmlns="http://www.niku.com/xog/InvokeAction">
<returnValue>false</returnValue>
</ProcessResult>
</soapenv:Body>
</soapenv:Envelope>
In the affected PPM versions, the InvokeAction Response appears as:
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
<soapenv:Header/>
<soapenv:Body>
<ProcessResult xmlns="http://www.niku.com/xog/InvokeAction"/>
</soapenv:Body>
</soapenv:Envelope>
Note: The <returnValue> tag and value are missing in PPM Webservice InvokeAction Response.
Expected Result: The <returnValue> tag is present in the PPM webservice response.
Actual Result: The <returnValue> tag is missing in the PPM webservice response.
The absence of the returnValue tag is causing PPM processes expecting a returnValue to fail. Often times, the customer will expect a returnValue of either true of false in order to help them determine if the process launched completed correctly.
Cause:
CLRT-72166 - Missing returnValue Tag in the Webservice Invokeaction Process
Resolution:
Our sustaining team reviewed CLRT-72166 and closed it as they are not planning to make any changes to this area of the product
Workaround:
- Visit http://hostname:port/niku/wsdl/InvokeAction/Process?download=true
- Save the contents to disk when prompted
- Edit the file and change the line from:
<xsd:element name="returnValue" type="xsd:boolean" minOccurs="1" maxOccurs="1" />
to:
<xsd:element name="returnValue" type="xsd:boolean" minOccurs="0" maxOccurs="1" /> - Save the file
- Re-generate the Webservice proxy code in your development environment using this file as the source and compile, deploy, and test as normal.
Additional Information:
For more details please review the Customer Reported Defect Resolution Policy for CA PPM