Missing RA tabs in AWI

Document ID : KB000120014
Last Modified Date : 09/11/2018
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Issue:

Under certain conditions RA objects (i.e. SOAP job) will be missing tabs when creating or editing a object. The missing tabs will be specific to the RA solution that related to the object. For example, if you create a WEBSERVICESOAP job the tab titled 'Web Service' would be missing.

Check if the plugin is installed. 
  • Open AWI
  • Click the drop down on the top right corner of the AWI and choose 'About'
  • This will return a list of installed plugins. Look for a message'Not Installed Plug-ins'. See the screen capture below:

User-added image

Cause:

This article will cover two reasons that could potentially cause this issue:

1. The plug-in is missing or corrupt. 
2. The user who started Tomcat does't have permission to the jar file

You can check this by following the steps below:

  • Login to client 0000
  • Open the Process Assembly perspective
  • From the explorer tab choose the folder 'STORE'
  • The 'STORE' folder contains UC_ECC_PLUGINS object. This includes every plug-in that is currently installed.
  • If the plugin is listed but you don't see the tab this could be caused by the AWI not having permission to access the jar file. Check for the following text in the AWI log file: 
Caused by: java.io.FileNotFoundException: /u00/app/tomcat8/apache-tomcat-8.5.32/temp/ecc-plugins/ecc-plugin-ECC-AE-SHEET-RA-WEBSERVICE-SOAP-504e90361b8ce959d1bc2716bf640b28.jar (Permission denied)
Resolution:
If the plugin is missing you can run the DB Load utility and load the agent solution. Alternatively, open the UC_ECC_PLUGINS object and upload the plugin manually.

If the plugin is listed in the UC_ECC_PLUGINS make sure Tomcat is started with a user with root permission.