Missing Metrics on Robot even after updating null ci_metric ID's

Document ID : KB000045093
Last Modified Date : 01/02/2019
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Issue:

In Unified Service Manager (USM) at times you get a issue where robot metrics tab show no data.

 

Cause:
One reason why CI_METRIC_ID's from a probe might not populate has to do with the niscache folder. sometimes the niscache folder is empty or sometimes there is a duplicate robot device ID in the niscache which prevents the metrics from getting associated with the right robot.
Resolution:
First step -- stop the robot, delete the entire contents of niscache folder including robot device ID file, and start it up again. make sure that you actually see new files populate into the niscache folder.

Next -- stop discovery_server and delete any folders under probes\service\discovery_server\ which are named after hubs.
Set log level 3 on discovery_server and activate it