Minimum Access Required for WCC Batch Utilities

Document ID : KB000013975
Last Modified Date : 14/02/2018
Show Technical Document Details
Question:

What is the minimum level of access required for the user specified in the -u argument of the WCC Configuration and Monitoring Batch Utilities?

Answer:

The user specified with the -u argument must have access to the application behind the batch utility being executed. For example, when running the wcc_config utility, the -u <user> must be granted access to the "Configuration" application within the WCC Application Access EEM policy.

 

 

 

Additional Information:

The level of access required, especially for the Configuration Batch Utility, is very powerful. A user with that access can cripple WCC to an unusable state. Therefore, when running these utilities within a script for automation purposes, it is highly recommended to run the utilities with an encrypted arguments file. This will avoid exposing the user and password in plain text within a script. Steps for creating and using encrypted argument files with the batch utilities can be found at the following links...

wcc_config

https://docops.ca.com/ca-wla-ae-wcc/11-4-2/en/administrating/ca-wcc-configuration/configuration-batch-interface#ConfigurationBatchInterface-EncryptCommandLineArguments

wcc_monitor

https://docops.ca.com/ca-wla-ae-wcc/11-4-2/en/administrating/ca-wcc-configuration/monitoring-batch-interface#MonitoringBatchInterface-EncryptCommandLineArguments