migration to the current Version the PTXMAN Started Task got message PDT0712

Document ID : KB000021879
Last Modified Date : 14/02/2018
Show Technical Document Details

Question: 

When doing a migration to the current Version the PTXMAN Started Task received error message:

PDT0712 DATASET VALIDATION FAILED/VERSION 19.00 NOT COMPATIBLE WITH DETECTOR VERSION IN USE.

How to solve this problem?

 

Answer: 

PDT0712 is an indication of using an incompatible datastore. The product release notes states the following:

Datastore and Profile Compatibility

Datastores and profiles (collection and report) from the current release are not compatible with the datastores and profiles from previous releases.

However, you can use the provided batch utilities to create, copy, and delete your datastores and profiles and to perform the following tasks:

  • Carry forward data from your previous release datastores and profiles.
  • Copy data from an existing datastore to one that is larger or has a different number of collection intervals.
  • Maintain profiles for all of your DB2 subsystems from a centralized location

 

The PDT0712 message occurs when a Datastore from a previous release (e.g. r15) is used to collect data in a newer release (e.g. r19). A new Datastore must be created for the new release. Afterwards, you can run the PDTDSCPY member in your High.Level.CDBASRC library to copy the data from your Old Datastore into your new one.

 

Additional Information:

Starting with release 16, datastores created by release 15 & above can be used without having to run the PDTDSCPY conversion job. However, once the datastore is viewed using the higher release, it can no longer be viewed by the older release unless it's appropriate Datastore Compatibility PTF is applied.