MIF File inventory does not work or stops working

Document ID : KB000117711
Last Modified Date : 17/10/2018
Show Technical Document Details
Issue:
Mif (Machine Information File)  file that previously was working is no longer updating and new machines generate no inventory at all for this mif file. Old .MNV files do not get updated in "%sdroot%\..\Agent\units\00000001\uam" nor in "%sdroot%\..\Agent\units\00000001\uam\BAK". If .MNV file in "%sdroot%\..\Agent\units\00000001\uam\BAK" or "%sdroot%\..\Agent\units\00000001\uam" is deleted, a new one is not generated.
No errors are seen in any Asset Management logs to indicate what the problem is.
Environment:
Any supported CA Client Automation environment running Asset Management
Cause:
An improperly formatted value within a MIF file can prevent the file from processing and any update to a previously working MIF file can potentially introduce such an issue.
In this case the item: Value = "Smith Chris (PIA - AT/"St. Polter")"  is an invalid line within the mif file. You cannot put double quotes within a double-quoted value.
Resolution:
The solution is to simply replace the internal double-quotes with single-quotes and then save the MIF file:

Value = "Smith Chris (PIA - AT/"St. Polter")"    ==>    Value = "Smith Chris (PIA - AT/'St. Polter')"