Metrics tab not working after upgrading

Document ID : KB000094212
Last Modified Date : 03/05/2018
Show Technical Document Details
Issue:
When clicking in the metrics Tab of all contracts the we receive the below error: 

Server Error in '/' Application. 
-------------------------------------------------------------------------------- 

Cannot add a column named 'Metric_toremove': a nested table with the same name already belongs to this DataTable. 
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.Data.DuplicateNameException: Cannot add a column named 'Metric_toremove': a nested table with the same name already belongs to this DataTable. 

Source Error: 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. 

Stack Trace: 


[DuplicateNameException: Cannot add a column named 'Metric_toremove': a nested table with the same name already belongs to this DataTable.] 
System.Data.DataTable.set_TableName(String value) +334 
Oblicore.Utils.Data.DataSetHelper.ChangeTable(DataSet ds, String originTableName, DataTable dt) in D:\Build\Branches\8.3.5-OnGoing\BuildDir\NetFoundations\src\OblicoreUtils\Data\DataSetHelper.cs:99 
Oblicore.Web.Controls.Grid.ConvertDataSource() +333 
Oblicore.Web.Controls.Grid.DataBind() +27 
Oblicore.Web.Contract.MetricList.BindGrid() +94 
Oblicore.Web.Infrastructure.OblicoreBase.OnLoad(EventArgs e) +781 
Oblicore.Web.Infrastructure.OblicoreList.OnLoad(EventArgs e) +14 
System.Web.UI.Control.LoadRecursive() +87 
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2000 
 
Resolution:
installing Microsoft .Net Framework 4.5.2 on the server fixed the problem. 

As per the installation instructions: 

"Note:CA Business Service Insight does not support .Net Framework 4.5. For Windows 2012, .Net 4.5 is the default. Update the .Net Framework to 4.5.1 or 4.5.2."

https://docops.ca.com/ca-business-service-insight/8-3-5/en/installation/install-ca-business-service-insight-on-a-multi-tier-environment