Menus Missing from Admin UI

Document ID : KB000009091
Last Modified Date : 14/02/2018
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Issue:

Newly installed Admin UI (WAMUI) is not showing all the expected menus.  The Federation menu is missing, and the Infrastructure menu is missing items.

Environment:
All supported releases of the Single Sign On (Siteminder) Administrative User Interface.
Cause:

The Admin UI will not show menus to which the logged in administrator does not have access.

Resolution:

Use a superuser account to grant the necessary access.  While non-superuser accounts may grant access to other administrators, non-superuser accounts can only grant other administrators access to objects which they have access, so a non-superuser account may be used for this task so long as that administrator has sufficient access.

Additional Information:

Depending on how a policy store was initially created and/or migrated, some federation objects may be missing from the policy store and can cause the Federation or one of its sub-menus to be missing.  After confirming this is not caused by a permissions issue as outlined above, follow the steps to import the data definitions and default objects per the installation guide.

 

Instructions for LDAP policy stores:
https://docops.ca.com/ca-single-sign-on/12-52-sp1/en/installing/install-a-policy-server/configure-ldap-directory-server-policy-session-and-key-stores

 

Instructions for ODBC policy stores:

https://docops.ca.com/ca-single-sign-on/12-52-sp1/en/installing/install-a-policy-server/configure-odbc-databases-as-policy-session-key-and-audit-stores