Menu under Catalog tab is not available in Service Catalog

Document ID : KB000100893
Last Modified Date : 12/06/2018
Show Technical Document Details
Issue:
Somehow during the upgrading process from 17 to 17.1 the EEM filters were not properly updated. As consequence, administrators are not able to create and edit forms because the menu under Catalog tab is not available.
 
Environment:
Service Catalog 17.1
Cause:
It is not a normal behavior, but seems the installer was not able to complete all integration steps between Service Catalog and EEM. Filters on EEM side were not properly updated and as consequence the menu under Catalog tab is not available.
Resolution:
Please follow the below procedure to change the filters:

Logon to EEM:
Application: Service Catalog
Username: eiamadmin 
Password: <enter the eiamadmin password> 

User-added image
  • Go to "Manage Access Policies" tab.
  • On "Search Policies", select "Explicit Denies" tab.
  • On "Access Policies", select "Guinode".
User-added image
  • In the right-hand-pane, see "Access Policies - Guinode".
  • Scroll to the right and find the "Filters" column.
User-added image

When you see a filter without "17.1" then: 
  1. Open that "Guinode" access policy (click on it).
  2. Scroll down to the "Filter".
  3. Open the filter to edit (click on the pencil-icon).
  4. Go to "Right type / value".
  5. At the end, add "17.1".
  6. Click save.
  7. Click close.
User-added image
  • Repeat the steps above for each policy.
Important: Next you need to do this for "Launchpad" too. 
  • Go to "Manage Access Policies" tab.
  • On "Search Policies", select "Explicit Denies" tab.
  • On "Access Policies", select "Launchpad".
User-added image
  • In the right-hand-pane, see "Access Policies - Launchpad".
  • Scroll to the right and find the "Filters" column.
User-added image

When you see a filter without "17.1" then: 
  1. Open that "Launchpad" access policy (click on it).
  2. Scroll down to the "Filter".
  3. Open the filter to edit (click on the pencil-icon).
  4. Go to "Right type / value".
  5. At the end, add "17.1".
  6. Click save.
  7. Click close.
User-added image
  • Repeat the steps above for each policy.
Then restart the Service Catalog service.