MDB Install: During a new MDB install or upgrade, error code 9024, a post install step failed, is received.

Document ID : KB000018488
Last Modified Date : 07/03/2018
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Issue:

While running the installation of CA client Automation during the setup or upgrade of the MDB, the following error is seen:

Error Code: 9024
Post install step failed
failed to apply post install step [sqlcmd.exe -S "$fqslserveraddr" -d $dbname -E -e -i .\mdb_install\mssql\synonyms.sql]


Figure 1

Environment:
Client Automation (ITCM) -- any version.
Cause:

The problem is that the following file is missing from the install media: 
..\WindowsProductFiles_x86\CCS\MdbOnly\database\mdb_install\mssql\synonyms.sql

This can happen depending on the software used to extract the DVD media.  The synonyms.sql file is 0kb in size, which some applications will skip when extracting the DVD media. As the file is empty and checked by the MDB installer,

Resolution:

1- You can manually create the missing file at the path mentioned.
  --or--
2- Use WinRar to extract the .ISO file
  --or--
3- Run the MDB installation first using 'setup.bat' from the following folder:
..\WindowsProductFiles_x86\mdb