Maximum number of target hosts has been reached

Document ID : KB000007844
Last Modified Date : 14/02/2018
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Issue:

Customers using the remote agent to run their batch may receive an error message indicating "Maximum number of target hosts has been reached," and furthermore resulting in the job not processing.

Environment:
Any OS.
Cause:

This issue is attributed to licensing. There is a licensing limitation of 6 target hosts per agent installation. That is to say that for every Workload Automation Agent that is installed on any given server, you can have up to 6 remote target hosts defined under that agent for remote processing. Once you reach the license limitation, you will receive the error message "Maximum number of target hosts has been reached" and your job will not run.

Resolution:

Remove the remote agent from the configuration either by deleting or moving the agent properties file located in the <agent_install_dir>/config/proxy directory. You can install another agent on another server and then configure up to 6 more remote agents there. Or, you can just install an agent on the server in question.