Master goes into STOPPED status, Log files shows multiple AwE-9999 errors

Document ID : KB000089916
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Affects Release version(s): 7.1

Master goes into STOPPED status, Log files shows multiple AwE-9999 errors
Resolution:

Symptoms

The master stops eventually and goes into a status STOPPED. The RmiServer log file shows multiple AwE-9999 error messages, including:


ErrorMsg: AwE-9999 Internal error
Details: rfp0: null
java.lang.RuntimeException: worker has been running for xxxxxx ms

ErrorMsg: AwE-9999 Internal error
Details: rfp
java.lang.RuntimeException: thread pool getting backed up, haven't processed work for xxxxxx milli-secs  queue size is xx


Cause

This issue was seen a few times in version 7.1 and in most cases it was related to a timeout issue.


Resolution

The timeout settings can be modified, in order to give the agent more time to communicate with the master:

1. go to the 'site' folder and open the awenv.ini file

2. insert the following lines in the [default] section:

ResponseTimeout=300 

read_timeout=300

3. Save the file and restart the processes for the changes to take effect