CA UIM maintenance mode options do not show in USM

Document ID : KB000033981
Last Modified Date : 03/07/2018
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Issue:

UIM users are unable to view or manage maintenance mode.

Environment:
UIM 8.4x
UIM 8.5x
Cause:
In certain cases, the upgrade processes may not reinitialize the ACL's in the hub's security.cfg.
Resolution:
1. On the primary hub, check the file \\Nimsoft\probes\service\distsrv\base_acls.cfg and make sure it has the ACLs below. If the are not there, you can manually add them by copy pasting the below.
<Edit Maintenance Mode Devices>
desc = Edit devices affected by a maintenance mode schedule type = UMP access = admin </Edit Maintenance Mode Devices>

<Edit Maintenance Mode Schedules> desc = Create, edit and delete maintenance mode schedules type = UMP access = admin </Edit Maintenance Mode Schedules>

2. In Infrastructure Manager, navigate the distsrv probe on the primary hub.

3. With the distsrv probe selected, press "Ctrl-P" the probe Utility (pu) should appear.

4. In the probe commandset, select callback set_acl_init with the parameter value "base_acls.cfg". The callback updates the security.cfg with the ACLs, it will not delete any ACLs, nor change any ACLs.

initialize acl


5. In infrastructure manager, open Security -> Manage Access Control List. Check to make sure the ACL has Edit Maintenance Mode Devices, and Edit Maintenance Mode Schedules selected.

6. Logout, and log back in with the user, the issue should now be resolved.
Additional Information:
maintenance_mode (Maintenance Mode)

https://docops.ca.com/ca-unified-infrastructure-management-probes/ga/en/alphabetical-probe-articles/maintenance_mode-maintenance-mode

Set Maintenance Windows for Groups

https://docops.ca.com/ca-unified-infrastructure-management/8-5-1/en/using-ump/the-unified-service-manager-portlet/create-and-manage-groups-in-usm#CreateandManageGroupsinUSM-SetMaintenanceWindowsforGroups