MAILEATER - REPLY_TO_ADDRESS

Document ID : KB000097144
Last Modified Date : 18/05/2018
Show Technical Document Details
Issue:
Even though you have disabled the "Use address for reply" option on a MAILEATER mailbox, all emails generated by MAILEATER are coming with the sender set in OPTION "mail_reply_to_address".
What causes the user, when replying to a message, to respond to the wrong mailbox.

Steps to Reproduce:
1) set SDM's Email option mail_reply_to_address to: SDM@test.com

2) Mailbox maileater address: maileater1@test.com

3) Mail box has Use Reply-To Address = YES

4) Ensure the mail box has a rule to eat a mail has below properties
[ \t\r\n]incident[ \t\r\n]
Create/Update Object
Reply: Email

5) make sure the user sending email has Notifications set for Email on the contact record for Normal notification

6) Send an email to the above mail box to let it create a ticket.

7) Check the reply the user gets from maileater now - it'll be like this:
From: SDM@test.com
Reply-To: SDM@test.com

(if you enable verbose on pdm_maileater_nxd.c you'll see something like: pdm_maileater_nxd.c 5584 Reply command is "pdm_mail -s "Service Desk Incident Response" -e "ticketrequestor@test.com""

8) change the mail box and set: Use Reply-To Address = No
(restart of maileater is not needed, but you can do it anyway)

9) repeat #6 above. Verify #7. Result is exactly the same, which is bad. Verbose log shows exact same thing as in #7 too

Actual Results:
As Reply-To Address is switched off on mail box, maileater should instead have changed the mail reply to something like:
"pdm_mail -s "Service Desk Incident Response" -e "ticketrequestor@test.com"" -T "maileater1@test.com"

As mail eater does not set the -T, pdm_mail just seems to set the -T from the SDM option mail_reply_to_address
Environment:
CA Service Management r14.1.x
Cause:
This issue is caused by: DE40337
Resolution:
This issue is currently under review as DE40337