LSS: END TIME FOR A CHAT SESSION IS NULL

Document ID : KB000096556
Last Modified Date : 01/06/2018
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Issue:
What causes the End Time for a Chat Session to be left empty/null. When running the below query against the mdb, the endEpoch field is null. 

select * from sa_virtual_session


 
Environment:
SDM 14.1, 17.0, 17.1
Cause:
A sudden drop in the session causes SA to write null to the database. This can be due to the service being restarted or even a network issue. When you initiate a chat, the field gets a null value and it isn't until the session is ended that the time is written. To test and replicate this:

1) Initiate a chat session 

2) Check the database using the following query while the chat is active: 

select * from sa_virtual_session 

3) Note that endEpoch field has null entry 

4) Restart service desk services and you will get a prompt that "connection to the server has been lost" and the chat session is ended 

5) Run the same query and you will still see null entries. 

 
Resolution:
To track down what may have caused the null entries, check the std logs to see if the server was restarted or maybe there was a network connection issue at the time.