Login to REST is failing

Document ID : KB000120007
Last Modified Date : 06/11/2018
Show Technical Document Details
Issue:
When attempting to login via REST API calls, the login is unsuccessful and is being rejected.  Need to know what may be causing the issue. 

jrest.log presents the following error:
11/01 15:58:11.501 [http-bio-8050-exec-1] ERROR SecurityInInterceptor 393 Basic Authorization failed (Login failed for userid (testuser1); no default role found for session type (10)) 
Environment:
Service Desk Manager 14.1 and higher
Cause:
The end user is attached to an access type whose "REST Web Service API Role" entry is deficient.
Resolution:
  • Verify the access type that is in place for the specified end user has a default role specified for the given access type on "REST Web Service API Role".  
  • Check that the given role under "REST Web Service API Role" has the following set on its Function Access (required to run any REST web services activities): 

    Administration : View 
    Reference : View 
    Security : View 
    Stored Query : View 
Additional Information:
See also:  KB000044903:  How to restrict access to some mobile user of CA Service Desk Manager?
https://comm.support.ca.com/kb/How-to-restrict-access-to-some-mobile-user-of-CA-Service-Desk-Manager/kb000044903