Login error: U0052010 UCUCM: Login '%' for connection '%' could not be resolved. Reason: 'no_Login_Entry'

Document ID : KB000087350
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
U0052010 UCUCM: Login '%' for connection '%' could not be resolved. Reason: 'no_Login_Entry'

'Test Connection' fails with the above error message when you use a newly created LOGIN where Agent name is specified (not *) and has a domain/user.

Investigation

Update the LOGIN to use * instead of the Agent name, and the 'Test Connection' is successful.
Change the LOGIN to use the Agent name again, and the 'Test Connection' is still successful.

 
Cause:
Cause type:
Defect
Root Cause: The Engine pushes the connection information along with the LOGIN CREDENTIALS into a cache. Changing the Login does not affect the cache hence it holds old/outdated information. Due to technical reasons this behavior was changed with a major release.
Resolution:
Update to a fix version listed below or a newer version if available.
 

Fix Status: Released

Fix Version(s):
Automation Engine 12.0.0
Additional Information:
Workaround :
Open the corresponding Connection Object and save it. 
This triggers a cache refresh and renews the last modification date of the connection in order to inform the Agent to pull it again from the Engine.