Login error after apply APM 12.9 C3 patch

Document ID : KB000008986
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Installed CA Asset Portfolio Management 12.9.03 (RO87789) and the login errors with:
System.Data.OracleClient requires Oracle client software version 8.1.7 or greater

Environment:
CA Asset Portfolio Management 12.9, C3
Resolution:

The CA Asset Portfolio Management 12.9 C3 patch cleared the database and system connection entries in the
\CA\ITAM\Web Server\ CA.Common.LoadConfigurationAttributes.dll.config file.

The correct database connection entries were present in the \CA\ITAM\Application Server directory. 

To resolve:

1.  Copy the file from the \CA\ITAM\Application Server\bin directory to the \CA\ITAM\Web Server\bin directory. 

2.  Perform an IISRESET on both the APM application and APM web servers.