local.properties is updated with proxy details but Workstation is not able to reach the endpoint.

Document ID : KB000009145
Last Modified Date : 15/11/2018
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Issue:

The local.properties file was updated with the proxy  details as per the below properties and the Workstation was restarted.
#lisa.http.webProxy.host=gateway.zscaler.net
#lisa.http.webProxy.port=80

#lisa.http.webProxy.ssl.host=gateway.zscaler.net
#lisa.http.webProxy.ssl.port=80 
 

When executing a test case, we are not able to reach the endpoint.

The same endpoint is accessible via web browser.

Environment:
All supported DevTest releases.
Cause:

One of the reasons is that the proxy information is not correct.

Resolution:

If you are able to reach the endpoint via web browser, verify what is the proxy settings for the browser.

Open the browser settings and LAN settings.

If the option enabled is Use Automatic Configuration Script, copy the whole address specified and try to access it via browser.

A PAC file will be downloaded.

Try to open this file with a text editor.

Looking at the PAC file try to identify your proxy details.

Then update your local.properties with the proxy details. 

Here is more information about proxy.pac file: Autoconfigure Scripts for Proxy Settings