List View portlet taking long time to appear

Document ID : KB000111007
Last Modified Date : 03/09/2018
Show Technical Document Details
Issue:
We have a portlet on a List View in UMP, that is taking a long time (minutes) to appear but the other portlets in the same view appear much quicker. I have managed to grab the t-sql query that is used to generate the portlet and have noticed that there is an index hint in the query that forces the query to use a certain index. If I comment the index hint out of the query, the query returns data in seconds rather than minutes with the index hint in place. 

Below is an excerpt from the query:

       LEFT JOIN (SELECT qos_c2.table_id, qos_c2.source, qos_c2.origin, qos_c2.target, SUM(qd_c2.samplevalue) AS samplevalue 
                      FROM s_qos_data qos_c2 JOIN 
                           RN_QOS_DATA_0202 qd_c2 
                             WITH (INDEX(RN_QOS_DATA_0202_idx1)) 
                             ON (qd_c2.table_id = qos_c2.table_id AND qd_c2.sampletime > @P0) 
                      WHERE ( qos_c2.qos = @P1  ) 
                      GROUP BY qos_c2.table_id, qos_c2.source, qos_c2.origin , qos_c2.target  
                  ) qos_c2
              ON qos_c2.source = s_qos_data.source AND qos_c2.origin = s_qos_data.origin AND qos_c2.target = s_qos_data.target 


The query is Top 10 Interface Errors which uses QOS_INTERFACE_ERRORS_COUNT and the probe interface_traffic to output a chart with error counts over 1 hour & 24 hours
Environment:
SQL Server 2014 SP1
Resolution:
ump_listdesigner_8.5.2_HF1_Test.zip resolves this issue

If you have this issue please raise a support case and refer to Defect DE369749