lisa-test-invoke/api/v1/ issue

Document ID : KB000097212
Last Modified Date : 21/05/2018
Show Technical Document Details
Issue:
When accessing the lisa-test-invoke/api/v1/ & lisa-virtualize-invoke/api/v2 in devtest 10.3 we are getting the below exception in registry.log 

exception:

org.reflections.Reflections    - Reflections took 172 ms to scan 1 urls, producing 367 keys and 981 values 
ERROR io.swagger.util.ReflectionUtils - Failed to resolve 'file' into class
java.lang.ClassNotFoundException: file
    at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    at org.eclipse.jetty.webapp.WebAppClassLoader.loadClass(WebAppClassLoader.java:487)
    at org.eclipse.jetty.webapp.WebAppClassLoader.loadClass(WebAppClassLoader.java:428)
    at io.swagger.util.ReflectionUtils.loadClassByName(ReflectionUtils.java:42)
    at io.swagger.util.ReflectionUtils.typeFromString(ReflectionUtils.java:20)
Environment:
Devtest 10.3
Resolution:
As this lisa invoke test API call is using POST method, where it requires "file" as a parameter.
Since the input argument is missing while executing the REST service, you are getting an error. Please pass input argument "file" and attach the file path to run the test suite through this lisa-invoke call.
Additional Information:
More information about the lisa test invoke calls can be found from below link. (Make sure registry is running fine)
http://hostname:1505/lisa-test-invoke/api/v1/swagger-ui#