Linux 64bit Master

Document ID : KB000090009
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Linux 64bit Master
Resolution:
Detailed Description and Symptoms
At this time using Java 64 bit on a Linux Master is unsupported prior to Service Pack 10.

Investigation
Customers trying to use 64 bit Java on Linux machines have run into different issues like ELFCLASS errors or library mismatch problems if they are using versions prior to sp10.

Solution
Use Java 32 bit at this time on the Master machine as the libnativecalls file at this time (in $AW_HOME/exec) is built specific to 32 bit Java. We included the 64 bit version in sp10 and above.