LDAP users can not login on UVMS if one of the LDAP servers is not reachable

Document ID : KB000086453
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
The users receive a popup error message on Univiewer stating the following:

#################################################################
Error while retrieving the list of groups on LDAP, please check UVMS log for more details. 
#################################################################

Patch level detected:Univiewer Management Server 6.2.00
Product Version: Dollar.Universe 6.2.0

Description :Univiewer users can not login to UVMS while using their LDAP login.
Environment:
OS: All
Cause:
Cause type:
By design
Root Cause: The problem is related to the UVMS variable LDAP_MEMBERSHIP_AT_LOGIN which is by default set to Y
Resolution:
In order to avoid this problem from happening again you should set the variable LDAP_MEMBERSHIP_AT_LOGIN to N, since the group memberships on the Active Directory are not supposed to change several times a day.

In order to change it, go to node settings of uvms - advanced settigns ->
Update group membership at login (LDAP Synchronization mode only) --> No

Then restart the UVMS, the issue should not occur anymore.

Fix Status: Released

Fix Version(s):
Component: Univiewer.Management.Server
Version: Dollar.Universe 6.2.0
Additional Information:
Workaround :
N/A