Launching User Interface results in error message "Error in CreateProcess Call, Errorcode 2"

Document ID : KB000087995
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
Error in CreateProcess Call, Errorcode 2

Launching User Interface (UCDJ.exe) results in error:

0EMb0000001Ufos.png
Environment:
OS Version: N/A
Cause:
Cause type:
Configuration
Root Cause: User Interface is unable to find the installation of Java.
Resolution:

1. If Java is not installed, install the Java version that is supported for the Automation Engine version.

2. If Java is installed, define the path to the javaw executable file. Edit UCDJ.ini, found in the User Interface's bin directory.  By default, it will look like "cmd="javaw". Find the path to the javaw and add it here. The result would look like:

; command how to start the client
cmd="C:\Program Files (x86)\Java\jre1.8.0_101\bin\javaw" -Xmx1024m -XX:+UseG1GC -XX:MinHeapFreeRatio=40 -XX:MaxHeapFreeRatio=70 -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=../temp -Dsun.locale.formatasdefault=true com.uc4.ucdf.UCDialogFactory -U%User%



Fix Status: No Fix

Fix Version(s):
N/A
Additional Information:
Workaround :
N/A