Large numbers of RPC requests and high levels of CPU usage on Exchange servers running Data Protection

Document ID : KB000096804
Last Modified Date : 22/08/2018
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Issue:
There have been reports of large numbers of RPC requests and high levels of CPU usage on Exchange CAS (Client Access Servers) where the CA Data Protection Exchange Server Agent (ESA) has been installed.  With the Exchange Server under stress users are unable to access their emails. 

 
Environment:
CA Data Protection 14.x\15.x with Exchange Server 2010 and above.
Cause:
After analyzing dump files captured during high CPU spikes, CA Data Protection Engineering identified the issue as being caused by a legacy conversion process utilized on the Exchange Server Agent. 

 
Resolution:
To resolve this issue CA advises customers disable the conversion of RTF into HTML. 

To disable RTF to HTML conversion follow the steps below:

1. Create a registry key called "Email" under the registry hive below:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ComputerAssociates\CA DataMinder\CurrentVersion

2. Create "DontConvertBodyFromRTF" registry under the key

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ComputerAssociates\CA DataMinder\CurrentVersion\Email

Name : DontConvertBodyFromRTF 

Type : REG_DWORD 
Value: 1 

3. Restart the Exchange Server Agent (Policy Engine Hub)
Additional Information:
Please be aware that there are some known issues that can impact event rendering in the CA Data Protection iConsole.  Please refer to the following link for more information.
Message with Non-ASCII characters does not render correctly.

Please take care when you are making changes to the registry.  Take the appropriate back ups before proceeding.