Lac is Unavailable with http error 503

Document ID : KB000071644
Last Modified Date : 22/02/2018
Show Technical Document Details
Issue:
lac server throws  503 error while accessing through web browser
Environment:
Live Api Creator
Cause:
You would see below errors in the stack trace from the logs

java.lang.RuntimeException: Not enough privileges in admin database - the user for the admin database must have enough privileges to create, alter and drop tables

java.sql.SQLException: DDL is not permitted for a read-only connection, user or database.
 
Resolution:
Log seem to indicate that the admin database is read-only.

Please take a look at the files (and directories) that make up the admin database, and see if any of them have read-only permissions for the user under which Jetty is running?

More specifically, this would mean going into the directory that contains LAC, e.g. CALiveAPICreator-Jetty-3.1.00.1, and looking at the subdirectory CALiveAPICreator/CALiveAPICreatorAdmin : who owns it and its contents, and what permissions do they all have?

You we'll need to determine what user LAC is being run as (or rather, what user Jetty is being run as). Does this user not have full read/write permissions to the CALiveAPICreator/CALiveAPICreatorAdmin directory and its contents?